Known Issues
This section outlines some known issues.
Cisco Switch Compatibility With 100 Series
Energy Efficient Ethernet/Flow Control (Pause Frames) Compatibility Table
Cisco >> Vivi | Energy Efficient Ethernet on and Flow Control on | Energy Efficient Ethernet on and Flow Control off | Energy Efficient Ethernet off and Flow Control on | Energy Efficient Ethernet off and Flow Control off |
1Gb & AC Adapter | Compatible | Incompatible | Compatible | Incompatible |
1Gb & PoE Adapter * | Incompatible | Incompatible | Compatible | Compatible |
100Mb & AC Adapter | Incompatible | Incompatible | Compatible | Compatible |
100Mb & PoE Adapter | Incompatible | Incompatible | Compatible | Compatible |
*This combination is included for completeness but in reality, it wouldn't be used as the PoE splitters only have 100Mbps throughput.
Current Bugs with Cisco Hardware
Catalyst 2960, 3560, 3750
Symptoms:
When using a Cisco 2960 with an incompatible configuration you will see severely degraded performance (lag and stuttering) as bandwidth throughput will be inconsistent. In some cases, you will even see constant line protocol flapping in the Cisco CLI as follows:
Dec 30 03:34:54: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/26, changed state to down Dec 30 03:35:04: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/26, changed state to up Dec 30 03:49:50: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/26, changed state to down Dec 30 03:50:00: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/26, changed state to up
Workaround:
The root cause of this issue is that Vivi does not support Energy Efficient Ethernet that is enabled by default on these models of switches and due to a Cisco bug, it is not disabled for devices running at 100Mbps that do not support it as per the standards.
It can be disabled with this command in the Cisco CLI as follows:
CLI Command: 2960X(config-if)#no power efficient-ethernet
Further information can be found at the Cisco website: https://bst.cloudapps.cisco.com/bugsearch/bug/CSCus35889
Catalyst 9300 & 3850
Symptoms:
Multi-gig switches such as the 9300 & 3850 fail to auto-negotiate with Vivi resulting in no network connectivity.
Workaround:
Update the firmware for your Vivi Boxes to the latest version.
HP Audio Drivers
One of the most common support requests received by Vivi Support is the reporting of sound being in sync between the device you're presenting with and the Vivi Box.
This means that when you turn the volume up or down on your HP device, this also turns the volume up and down on the Vivi Receiver.
This issue tends to occur on HP devices only, and the underlying reason for this is that HP runs a Conexant driver that modifies sound differently for connected devices.
Usually when you modify your volume up, down or to mute, what you're actually doing is adjusting the sound via the WASAPI (Windows Audio Session API).
However, with the Conexant driver, this happens much further up the sound pipeline and therefore mutes any sound further down.
The way in which to fix this is to force the sound device to utilise WASAPI. HP recommends you do this by turning off hardware acceleration on the audio device.
See their support page for instructions: https://support.hp.com/us-en/document/c05851794
In some cases, this doesn't resolve the problem, as the particular sound driver installed has malfunctioning hardware acceleration.
In this scenario HP recommends you install one of their updated drivers to solve the issue. We only have a limited number of drivers, which have been kindly sent to us by schools who have experienced the issue.
If you do not see your device listed below you will need to contact HP directly, for the relevant driver. If you are able to send the driver to us we gratefully add it to our list.
See the following table for the relevant driver and download links:
2015 Models |
HP EliteBook Folio 1040 G3 |
HP EliteBook 1030 G1 |
HP EliteBook 840/848/850 G3 |
HP ProBook 640/650 G2 |
HP ProBook 11 G1 EE |
HP ProBook 11 G2 EE |
HP EliteBook Folio G1 |
HP Elite x2 1012 G1 |
HP ProBook 430/440/446/450/470 G3 |
HP EliteBook 820/828 G3 |
Driver for 2015 models: https://downloads.vivi.io/support/2015.zip
2016 Models |
HP ProBook x360 11 G1 EE |
HP ProBook x360 11 G2 EE |
HP ProBook 640/650 G3 |
HP EliteBook 840/848/850 G4 |
HP EliteBook x360 1020 G2 |
HP Elite x2 1012 G2 |
HP EliteBook x360 G2 |
HP ProBook 430/440/450/470 G4 |
HP EliteBook 820/828 G4 |
HP Pro x2 612 G2 |
Driver for 2016 models: https://downloads.vivi.io/support/2016.zip
2017 and 2018 Models |
HP ProBook 430/440/450/470 G5 |
HP EliteBook x360 1040 G5 |
HP EliteBook x360 1030 G3 |
HP ProBook 640/650 G4 |
HP EliteBook 840/846/850 G5 |
HP EliteBook 840r/846r G4 |
HP EliteBook 840/846 G5 HC |
HP Elite x2 1013 G3 |
HP ProBook x360 440 G1 |
HP EliteBook 830/836 G5 |
HP EliteBook 1050 G1 |
Driver for 2017 and 2018 models: https://downloads.vivi.io/support/2017_2018.zip
Vivi App Disappearing from user devices.
Symptoms
Vivi app will disappear from the user device. This often happens while the app is in use.
Cause
Some Antivirus software will identify Vivi as a threat and move the app to quarantine or delete it completely.
Workaround
We recommend adding Vivi to your AV whitelist to prevent this issue from reoccurring.